Вопрос по информатике:
Помогите по информатике!
Дана последовательность целых чисел, 0 - конец последовательности. Определите, сколько раз в последовательности меняется знак.
- 10.04.2018 17:43
- Информатика
- remove_red_eye 10053
- thumb_up 34
Ответы и объяснения 1
Var n, i, n1: integer;
begin
read(n);
i := 0;
n1 := 0;
while n 0 do
begin
if n1 * n < 0 then
i := i + 1;
n1 := n;
read(n);
end;
writeln(i);
end.
- 11.04.2018 18:28
- thumb_up 36
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.