Вопрос по информатике:
Составить программу для нахождения наибольшего общего делителя двух натуральных чисел M и N.
- 16.01.2018 17:38
- Информатика
- remove_red_eye 13431
- thumb_up 7
Ответы и объяснения 1
Pascal
var a,b,i,c,d:integer;
begin
writeln ('Введите два натуральных числа');
readln (a,b);
if (a>0) and (b>0) then begin
if (a=b) then writeln ('НОД = ',a) else begin
if (a>b) then c:=a else c:=b;
for i:=1 to c do begin
if (a mod i=0) and (b mod i=0) then d:=i;
end;
writeln ('НОД = ',d);
end;
end else writeln ('Неверный ввод');
end.
- 17.01.2018 14:23
- thumb_up 17
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.