Вопрос по информатике:
(1) вариант
1 написать программу которая вводит с клавиатуры одномерный массив из 10 целых двузначных чисел выводит количество элементов > 28 и их среднее арифметическое
2 написать программу которая выводит с клавиатуры одномерный массив из 6 целых чисел и выводит нечётные
3 написать программу ввода с клавиатуры последовательность целых чисел вычисляющую кол-во и сумму положительно ввёдных чисел
- 01.06.2018 19:14
- Информатика
- remove_red_eye 18946
- thumb_up 34
Ответы и объяснения 1
1. var a:array[1..10] of integer;
n, i: integer;
s:real;
begin
for i:=1 to 10 do
readln(a[i]);
s:=0;n:=0;
for i:=1 to 10 do
if a[i]>28 then begin s:=s+a[i]; n:=n+1 end;
if n>0 then writeln(n,s/n) else writeln('net >28')
end.
- 02.06.2018 19:20
- thumb_up 23
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.