Вопрос по информатике:
СОСТАВЬТЕ ПЛИЗ БЫСТРО!15БАЛЛОВ
1)Составьте программу вычесления суммы s=1+2^2+3^3+4^4+...+n^n.
2)Даны годовые оценки учеников класса по физике.Верно ли ,что количесвто пятерок больше,чем двоек?
3)Известна высота двадцати зданий.Найти минимальную высоту.
4Известна высота Двадцати зданий.Найти два максимальный значения
- 11.06.2018 06:43
- Информатика
- remove_red_eye 17835
- thumb_up 10
Ответы и объяснения 1
Var p, q: longint;
n, i, j, c: integer;
begin
// 1
write('n=');readln(n);
for i := 1 to n do begin
q := 1;
for j := 1 to i do q := q * i;
p := p + q;
end;
writeln ('Значение = ', p);
// 2
write('Число годовых оценок=');readln(n);
p:=0;
for i := 1 to n do begin
write('оценка: '); readln(c);
if c = 5 then p := p + 1
else if c = 2 then p := - 1;
end;
writeln(p > 0);
// 3
n := 20; p := MaxInt;
for i := 1 to n do begin
write('Введите высоту здания ', i, ': ');
readln(c);
if c < p then p := c;
end;
writeln('Минимальная высота: ', p);
//4
n := 20; p := -1;
for i := 1 to n do begin
write('Введите высоту здания ', i, ': ');
readln(c);
if c > p then p := c;
end;
writeln('Максимальное значение высоты: ', p);
end.
- 12.06.2018 06:25
- thumb_up 51
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.