Вопрос по информатике:
Дан одномерный массив из n целых чисел. Составить программу нахождения максимального и минимального элементов.
- 07.08.2018 12:45
- Информатика
- remove_red_eye 16784
- thumb_up 35
Ответы и объяснения 1
Var a:array of integer;
i,n,mn,mx: integer;
begin
write('размерность массива = ');
readln(n);
SetLength(a, n);
for i := 0 to n-1 do begin
write('a[',i,']=');
readln(a[i]);
end;
mn := a[0];
mx := a[0];
for i := 1 to n-1 do begin
if mn > a[i] then mn := a[i];
if mx < a[i] then mx := a[i];
end;
writeln('минимальный элемент = ', mn);
writeln('максимальный элемент = ', mx);
end.
- 08.08.2018 19:03
- thumb_up 23
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.