Вопрос по информатике:
Составьте программу вычисления количества трехзначных чисел, у которых цифры упорядочены строго по возрастанию .
- 19.10.2017 00:49
- Информатика
- remove_red_eye 14048
- thumb_up 29
Ответы и объяснения 1
Var
a1,a2,a3,i,n:integer;
a:array[1..10]of integer;
begin
writeln('Ввод трехзначных чисел');
for i:=1 to 10 do
readln(a[i]);
for i:=1 to 10 do begin
a1:= a[i] div 100;
a2:= (a[i] div 10 )mod 10;
a3:=a[i] mod 10;
if (a1 < a2) and (a2 < a3) then
n += 1;
end;
writeln(n);
end.
- 20.10.2017 22:55
- thumb_up 25
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.