Вопрос по информатике:
Составьте программу вычисления суммы нечетных чисел в диапазоне от 1 до 10
- 19.03.2015 05:27
- Информатика
- remove_red_eye 16078
- thumb_up 30
Ответы и объяснения 1
С помощью оператора while:
var
i,sum:integer;
begin
sum:=0;
i:=1;
while i<=10 do
begin
sum:=sum+i;
i:=i+2;
end;
writeln ('Summa: ',sum);
end.
Пойдет?
uses crt;
var
i: byte;
s: word;
begin
i := 1;
s := 0;
while i <= 10 do
begin
if i mod 2 0 then
s := s + i;
inc(i);
end;
writeln('Сумма нечётных чисел от 1 до 10: ', s);
readln;
end.
- 21.03.2015 00:55
- thumb_up 2
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.