Вопрос по информатике:
Написать программу которая находит сумму цифр числа
Паскаль
( ну или хотя бы идейку подкиньте)
- 07.07.2018 02:46
- Информатика
- remove_red_eye 985
- thumb_up 45
Ответы и объяснения 1
Program summa;
var a,x:integer;
i,s:integer;
begin
writeln('введите целое число');
readln( a );
x:=a;
s:=0;
while ( x0 ) do begin s := s + (x mod 10);
x := x div 10;
end;
writeln( 'Сумма цифр числа ',a,' = ', s );
end.
- 08.07.2018 00:57
- thumb_up 45
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.