Вопрос по информатике:
Program primer_1;
var v,a,b,c,r,h:real;
var num:integer;
begin
writeln('Введите значение num');
writeln('num='); readln(num);
case num of
1: writeln('Введите значения a,b,c');
write('a='); readln(a);
write('b='); readln(b);
write('c='); readln(c);
v:=a*b*c;
writeln('v=',v:8:3);
2: write('Bвежите значения r');
write('r='); readln(r);
v:=4/3*pi*power(r;3);
writeln('v=',v:8:3);
3: write('Введите значения r,h');
write('r='); readln(r);
write('h='); readln(h);
v:=1/3*pi*sqr(r)*h;
wrireln('v=',v:8:3);
else write(‘Введено число вне диапазона 1-3!’);
end.
пытаюсь написать программу в которой от того какую цифру из трех ты выберешь будет зависеть объем какой из трех фигур надо будет найти. Вижу что ошибка в использовании оператора case, как будто нельзя писать какие-то другие действия кроме write после 1: 2: 3:
- 05.07.2018 13:44
- Информатика
- remove_red_eye 12619
- thumb_up 11
Ответы и объяснения 1
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.