Вопрос по информатике:
Даны два натуральных числа. Выяснить в каком из них сумма цифр
больше.Написать программу в паскале абс,использую функцию.
- 18.06.2017 23:45
- Информатика
- remove_red_eye 1013
- thumb_up 26
Ответы и объяснения 1
Function summ (a : integer) : integer;
var
s : integer;
begin
s := 0;
while (a > 0) do
begin
s := s + a mod 10;
a := a div 10;
end;
summ := s;
end;
var
a, b : integer;
begin
read (a, b);
a := summ (a);
b := summ (b);
if a > b then write ('in 1') else if b > a then write ('in 2') else write ('eq');
end.
- 19.06.2017 10:29
- thumb_up 34
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.