Вопрос по информатике:
Известны три натуральных числа C– часы, M – минуты, S –
секунды. Написать программу используя условный оператор, которая
определяет время через 15 секунд.
Пожалуйста нужно сделать через Pascal !
- 16.09.2015 13:03
- Информатика
- remove_red_eye 2162
- thumb_up 9
Ответы и объяснения 1
Var
c,m,s:integer;
begin
readln(c,m,s);
if s>=45 then begin
m:=m+1;
s:=s+15-60;
end
else s:=s+15;
if m>=59 then begin
c:=c+1;
m:=0;
end;
if c>=24 then c:=0;
writeln(c,' ',m,' ',s);
end.
- 17.09.2015 19:34
- thumb_up 13
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.