Вопрос по информатике:
Помогите решить задачу по программированию, прошу :(
Кащей Бессмертный решил жениться на Василисе Прекрасной. Для реализации этого плана он выменял у Бабы-Яги волшебную яблоню, на которой через каждые m дней к вечеру вырастает молодильное яблоко. На обычного человека эти яблоки оказывают продолжительный эффект, но Кащей очень стар, суперстар, поэтому яблоко на него действует только один день. Чтобы Василиса окончательно забыла об Иване-царевиче, Кащею нужно ухаживать за Василисой не менее k дней подряд.
Первоначально у Кащея нет яблок, а до нового урожая нужно ждать m дней. Определите через какое минимальное количество дней Кащей сможет приступить к осуществлению своего коварного замысла.
Формат ввода
В первой строке ввода содержатся два целых числа k и m (1 ≤ k ≤ 106, 2 ≤ m ≤ 106).
Формат вывода
Вывести одно целое число – через сколько дней Кащей сможет начать ухаживание за Василисой.
Пример ввода
5 2
Пример вывода
6
- 05.07.2017 21:32
- Информатика
- remove_red_eye 16893
- thumb_up 40
Ответы и объяснения 1
Для ухаживания k дней подряд надо, чтобы k-e яблоко выросло к вечеру k-го дня. следовательно, начинать ухаживание можно не ранее, чем за k-1 день до вырастания последнего яблока. А поскольку на вырастание каждого яблока надо m дней, то k яблок вырастет в день номер m x k . Отступим от этой даты на k-1 день и получим p = m x k - (k -1)= k x (m-1) + 1
Проверим предложенную формулу на контрольном примере.
k=5, m=2, d=5x(2-1)+1=6.
var
m, n: integer;
begin
Write('Период созревания яблока, дней: ');
Readln(m);
Write('Количество дней ухаживания: ');
Readln(n);
Writeln('Номер первого дня ухаживания: ', n * (m - 1) + 1);
end.
Тестовое решение:
Период созревания яблока, дней: 2
Количество дней ухаживания: 5
Номер первого дня ухаживания: 6
- 06.07.2017 12:56
- thumb_up 44
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.