Вопрос по информатике:
Задача A. Счастливый билет.
Имя входного файла:
стандартный поток ввода
Имя выходного файла:
стандартный поток вывода
Ограничение по времени: 1 секунда
Ограничение по памяти: 256 мегабайт
Крокодил Гена и Чебурашка поехали в гости на трамвае. За ними увязалась Старушка Шапо-
кляк. Когда пассажиры заплатили за проезд и получили билетики, оказалось, что у одного из них
"счастливый билет"(сумма первой половины цифр равна сумме второй половины цифр). Старушка
Шапокляк помнит наставления своей бабушки ¾.. если съешь счастливый билет три дня тебе будет
счастье... Помогите Шапокляк определить, у кого из них счастливый билетик.
Формат входного файла
Вам даны номера трех билетов. По одному номеру в каждой строке. Длина номера билета четная
от 4 до 100000 символов. Длины номеров билетов могут быть разными.
Формат выходного файла
Выведите номер счастливого билета. Билеты нумеруются от 1 до 3. Счастливый билет может
быть только один. Если счастливых билетов нет, то выведите 0
- 21.03.2017 21:58
- Информатика
- remove_red_eye 6638
- thumb_up 30
Ответы и объяснения 1
Вот решение на языке С++
# include
# include
using namespace std;
int main()
{
freopen("input.txt","r",stdin);
freopen("output.txt","w",stdout);
char a,b,c,x,y,z;
cin.get(a);
cin.get(b);
cin.get(c);
cin.get(x);
cin.get(y);
cin.get(z);
if((a+b+c)==(x+y+z))
cout<<"YES";
else
cout<<"NO";
return 0;
}
- 22.03.2017 14:48
- thumb_up 13
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.