Вопрос по информатике:
Помогите написать программу в паскале!Очень надо!
Задана последовательность целых чисел,количество которых не превосходит 100.Требуется определить за один проход элемент с максимальным значением,а также число его повторений в последовательности.
- 27.10.2017 03:55
- Информатика
- remove_red_eye 12632
- thumb_up 44
Ответы и объяснения 2
Var
i,k,max:integer;
a:array[1..100]of integer;
begin
writeln('Исходная последовательность: ');
for i:=1 to 100 do
begin
a[i]:=random(200);
write(a[i],' ');
if a[i]>max then
begin
max:=a[i];
k:=1;
end;
if a[i]=max then
k:=k+1;
end;
writeln;
writeln('Максимальное значение: ',max);
writeln('Число повторений: ',k)
end.
- 28.10.2017 02:22
- thumb_up 36
Program maxof;
var ar: array [1..100] of integer;
i, j, posl: shortint;
max: integer;
begin
readln(i);
for j:=1 to i do begin
readln(ar[j]);
end;
max:=ar[1];
posl:=1;
for j:=2 to i do begin
if max = ar[j] then inc(posl);
if max < ar[j] then begin posl:=1; max:=ar[j] end;
end; writeln(max, ' x', posl);
end.
- 29.10.2017 02:52
- thumb_up 18
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.