Вопрос по информатике:
Составить программу в Паскале:
Из n введенных чисел найти максимальное значение среди положительных элементов.
- 03.02.2018 01:05
- Информатика
- remove_red_eye 17970
- thumb_up 31
Ответы и объяснения 2
Program abc;
type
mas = array[0..1000] of integer;
var
a: mas;
i, n, max: integer;
begin
WriteLn('Введите кол-во эл-тов массива:');
ReadLn(n);
for i := 1 to n do
begin
WriteLn('Введите значение элемента №', i);
ReadLn(a[i]);
end;
WriteLn('Все элементы массива имеют значение');
max := -1;
for i := 1 to n do
if a[i] > max then
max := a[i];
if max -1 then
Writeln('Максимальное значение положительного элемент = ', max)
else Writeln('Положительных элементов нет');
ReadLn;
end.
- 05.02.2018 21:58
- thumb_up 42
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.