Вопрос по информатике:
Помогите пожалуйста.Я вас отблагодарю!Даны два круга с общим центром
и радиусами R1
и R2
(R1 > R2).
Найти площади этих кругов S1
и S2,
а также площадь S3
кольца, внешний радиус которого равен R1,
а внутренний радиус равен R2:
S1 = P·(R1)2,
S2 = P·(R2)2,
S3 = S1 – S2.
В качестве значения P
использовать константу языка Паскаль
Входные данные: ввести два целых
числа R1
и R2
(1<=R1,R2<=100).
Выходные данные: вывести площади
этих кругов S1
и S2,
а также площадь S3
кольца, внешний радиус которого равен R1,
а внутренний радиус равен с
точностью до 3 цифр в дробной части в
разных строках.
- 10.10.2017 18:26
- Информатика
- remove_red_eye 4315
- thumb_up 50
Ответы и объяснения 2
Program zn2; Uses crt; Var s1, s2, s3: real; R1, r2: integer; Begin Clrscr; Repeat Write ('Enter r1, r2: '); Readln (r1, r2); Until (r1>=1) and (r2<=100); S1:=pi*sqr(r1); S2:=pi*sqr(r2); S3:=s1-s2; Writeln ('S1=', s1:0:3); Writeln ('S2=', s2:0:3); Writeln ('S3=', s3:0:3); Readkey; End.
- 11.10.2017 07:13
- thumb_up 20
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.