Вопрос по информатике:
Составить алгоритм и написать программу для решение задачи с использованием двумерных массивов и конструкций цикла в цикле:
Вычислить
сумму положительных элементов матрицы А (10х10), расположенных над главной
диагональю. Индекс номера строки i изменяется
от 1 до 9, а индекс номера столбца j изменяется от –i+1
до 10.
- 07.05.2018 19:52
- Информатика
- remove_red_eye 8896
- thumb_up 43
Ответы и объяснения 1
Var a:array[1..10,1..10] of integer;
i,j,sum,np: integer;
begin
for i:=1 to 10 do
for j:=1 to 10 do readln(a[i,j]);
sum:=0;
for np:=1 to 9 do begin
i:=np;
for j:=1 to np do begin
if a[i,j]>0 then sum:=sum+a[i,j];
i:=i-1;
end;
end;
writeln('Сумма элементов, расположенных выше главной диагонали равна ',sum);
readln
end.
- 08.05.2018 19:39
- thumb_up 12
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.