Вопрос по информатике:
Компоненты переменной v представляют собой ежедневный доход предприятия .Напишите программу которая подсчитывает средний ежедневный доход.(Относиться к турбо паскаль) Описание type Zi (это типо дни как на молдавском пишется )=(P,V,S,C,P,S,V)-дни недели
Venit(с нашего языка пришел или пришли)=array [Zi] of real;
var v:Venit;
- 14.02.2016 14:45
- Информатика
- remove_red_eye 14603
- thumb_up 38
Ответы и объяснения 1
Задача сводится к суммированию элементов массива V с целью нахождения их среднего арифметического. Конечно, такую задачу можно решать и без массива, поскольку нам придется все равно данные вводить с клавиатуры, но уж раз сказано, что "компоненты..." сделаем с массивом.
const
n = 7;
s = 'PVSCPSV';
var
v: array[1..n] of double;
i: integer;
m: double;
begin
Writeln('Вводите суммы ежедневного дохода по дням');
m := 0;
for i := 1 to n do
begin
Write(s[i], ': ');
Readln(v[i]);
m := m + v[i]
end;
Writeln('Средний доход за неделю составляет ', m / n:0:3)
end.
Тестовое решение:
Вводите суммы ежедневного дохода по дням
P: 142539
V: 363135
S: 217432
C: 57395
P: 294722
S: 115390
V: 184933
Средний доход за неделю составляет 196506.571
- 15.02.2016 21:14
- thumb_up 12
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.