Вопрос по информатике:
Составьте программу,которая проверяет,является ли человек заданного возраста школьником,если возраст школьника-от 6 о 17 лет,и выводит на экран соответствующее сообщение "Равны"либо "Неравны"
- 20.09.2018 23:33
- Информатика
- remove_red_eye 13171
- thumb_up 22
Ответы и объяснения 1
var
a: byte; //Возраст явно не больше 255 лет и не меньше 0 :)
begin
readln(a);
case (a) of
6..17:
writeln('Равны');
else
writeln('Не равны');
end;
end.
Но если нужно через if..then..else:
var
a: byte; //Возраст явно не больше 255 лет и не меньше 0 :)
begin
readln(a);
if ((a >= 6) and (a <= 17)) then
writeln('Равны')
else
writeln('Не равны');
end.
- 21.09.2018 00:19
- thumb_up 6
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.