Вопрос по информатике:
Дано натуральное трехзначное число N. Составьте программу, выводящую четырехзначное число, полученное приписыванием цифры разряда единиц исходного числа к нему же слева (в разряд тысяч).
- 26.09.2018 03:45
- Информатика
- remove_red_eye 4362
- thumb_up 48
Ответы и объяснения 1
Program Pr1;
uses crt;
var fl1,fl2:text;
n,tmp:string;
Begin
clrscr;
assign(fl1,'input.txt');
assign(fl2,'output.txt');
reset(fl1);
readln(fl1,n);
close(fl1);
tmp:=copy(n,length(n),1);
n:=tmp+n;
rewrite(fl2);
writeln(fl2,n);
close(fl2);
end.
- 27.09.2018 13:13
- thumb_up 10
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.