Вопрос по информатике:
№1
Требовалось написать программу, которая определяет, имеется ли среди введенных с клавиатуры положительных целых чисел а и Ь хотя бы одно четное. Была написана следующая программа:
• var a, b: integer;
• begin
• readln(a, b);
• a := a mod 2;
• if a > 0 then b := b mod 2;
• if b > 0 then
• writeln ('четных чисел нет')
• else
• writeln ('четное число есть');
• end.
Доработайте эту программу таким образом, чтобы задача решалась верно.
№2
С клавиатуры вводится трёхзначное число. Нужно вывести ответ «Да», если все его цифры четные, и ответ «Нет» в остальных случаях. Если введено не трёхзначное число, должно быть выведено сообщение «Неверное число».
- 01.09.2017 23:05
- Информатика
- remove_red_eye 13617
- thumb_up 40
Ответы и объяснения 1
N1
var a, b: integer;
• begin
• readln(a, b);
• a := a mod 2;
b := b mod 2;
• if (b > 0) and (a > 0) then
• writeln ('четных чисел нет')
• else
• writeln ('четное число есть');
end.
N2
#include
using namespace std;
int main()
{
int a;
cin >> a;
if(a 999) cout << "Неверное число" << endl;
else
{
int a1 = a/100;
int a2 = (a/10)%10;
int a3 = a%10;
if(a1%2==a2%2==a3%2==0) cout << "Да" << endl;
else cout << "Нет" << endl;
}
return 0;
}
- 02.09.2017 12:46
- thumb_up 6
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.