Вопрос по информатике:
Дан целочисленный массив из 20 элементов. Элементы массива могут принимать целые
значения от 0 до 10000 включительно. Напишите программу которая позволяет найти количество пар элементов массива, произведение которых нечетно , а сумма некратна 5. Под парой подразумевается 2 идущих подряд элементов массива
- 19.07.2016 14:44
- Информатика
- remove_red_eye 17150
- thumb_up 26
Ответы и объяснения 1
Const
n = 20;
var
i, k: integer;
a: array[1..n] of longint;
begin
Writeln('Введите с клавиатуры ', n, ' целых чисел через пробел');
k := 0;
Read(a[1]);
for i := 2 to n do
begin
Read(a[i]);
if ((a[i - 1] * a[i] mod 2) = 1) and ((a[i - 1] + a[i] mod 5) 0) then k := k + 1
end;
Writeln(#13#10, 'Найдено пар: ', k)
end.
Тестовое решение:
Введите с клавиатуры 20 целых чисел через пробел
10 24 18 35 35 16 52 163 265 210 318 45 18 35 62 10 84 90 425 300
Найдено пар; 2
- 20.07.2016 16:47
- thumb_up 12
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.