Вопрос по информатике:
Длина Московской кольцевой автомобильной дороги —109 километров. Байкер Вася стартует с нулевого километра МКАД и едет со скоростью vкилометров в час. На какой отметке он остановится через t часов?Программа получает на вход значения v и t. Если v>0, то Вася движется в положительном направлении по МКАД, если же значение v<0, то в отрицательном.Программа должна вывести целое число от 0 до 108 — номер отметки, на которой остановится Вася.
задача на паскале
- 03.02.2018 21:00
- Информатика
- remove_red_eye 16307
- thumb_up 11
Ответы и объяснения 1
Const
L = 109;
var
v, t, s: real;
n: integer;
begin
Write('Введите скорость Васи, км/ч: ');
Readln(v);
Write('Введите время в пути, ч: ');
Readln(t);
s := abs(v) * t;
n := trunc(s);
if s > n then n := n + 1;
n := n mod L;
if v > 0 then Writeln('Вася остановился на ', n, ' км.')
else Writeln('Вася остановился на ', L - n - 1, ' км.')
end.
Тестовое решение:
Введите скорость Васи, км/ч: 85.4
Введите время в пути, ч: 1.5
Вася остановился на 20 км.
- 04.02.2018 21:37
- thumb_up 50
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.