Вопрос по информатике:
Жили были дед и баба и был у них огород прямоугольной формы со сторонами A, B. После ссоры они решили поделить огород, при этом дед может взять себе не больше половины огорода (размеры участков после раздела должны быть целыми и участки прямоугольными). Вывести '1' - если участок деда оказался меньше, '0' - если участки равны.
Входные данные:
Во входном потоке в первой строке заданы целые числа A, B (A, B < 1000).
Выходные данные:
Вывести единственное целое число.
Пример входного файла (input.txt):
8 4
- 11.02.2018 21:37
- Информатика
- remove_red_eye 17232
- thumb_up 13
Ответы и объяснения 1
var
a, b: integer;
begin
assign(input, 'input.txt');
assign(output, 'input.txt');
reset(input);
rewrite(output);
readln(input, a, b);
if (a mod 2 = 1) then
writeln(output, b mod 2)
else
writeln(output, '0');
close(input);
close(output);
end.
- 12.02.2018 17:34
- thumb_up 29
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.