Вопрос по информатике:
ПОМОГИТЕ!!! СРОЧНО НА ЭКЗАМЕН!!!
Дано натуральное число н. Найдите число образованное перестановкой цифр исходного числа в обратном порядке. Формат входных данных. Входной файл содержит целое трехзначное число 101 <=н<=999. Гарантируется что оно не будет иметь концевых нулей.
- 01.01.2018 03:56
- Информатика
- remove_red_eye 2807
- thumb_up 7
Ответы и объяснения 1
Пишу на паскале. Я так понял суть программы в том чтобы она из числа 325 сделала 523. Если так и надо то вот код:
program prog;
var m,r,k,n,d:integer;
begin
writeln('Введите число n');
readln(n);
k:=n mod 10;
d:=n div 100;
r:=n div 10 mod 10;
m:=k*100+r*10+d;
writeln(m);
readln;
end.
- 02.01.2018 01:46
- thumb_up 24
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.