Вопрос по информатике:
Информатики, помогите составить программу, складывающую предложенные числа так, чтобы получилось круглое число от 100 до 1000 на языке pascal.
- 22.05.2017 19:04
- Информатика
- remove_red_eye 9569
- thumb_up 40
Ответы и объяснения 1
var
x, y, z: integer;
begin
writeln('-1 - конец ввода и вывод суммы');
repeat
readln(y);
if (y < -1) then
writeln('Эм... Не, не съем: отрицательная цЫфра.')
else
if (y >= 0) then
z := z + y
else
if (y = -1) then
if (z >= 100) then
break
else
writeln('Не, не годится, прибавь ещё чуток, до сотни не дотягивает');
if (z > 1000) then
begin
writeln('Всё, перевес. Сумма чисел больше 1000.');
exit;
end;
until (false);
writeln('Сумма примерно равна (если округлить) ', round(z / 10) * 10);
end.
- 23.05.2017 18:54
- thumb_up 5
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.