Вопрос по информатике:
срочно
Секретный замок для сейфа состоит из 10 расположенных в ряд ячеек, в которые надо вставить игральные кубики. Но дверь открывается только в том случае, когда в любых трех соседних ячейках сумма точек на передних гранях кубиков равна 10. (Игральный кубик имеет на каждой грани от 1 до 6 точек.) Напишите программу, которая разгадывает код замка при условии, что два кубика уже вставлены в ячейки
- 09.12.2017 19:37
- Информатика
- remove_red_eye 3768
- thumb_up 7
Ответы и объяснения 2
var
a: array [1..10] of integer;
i: integer;
begin
readln(a[1], a[2]);
write('Код замка: ', a[1], ' ', a[2], ' ');
for i := 3 to 10 do
begin
a[i] := 10 - (a[i - 1] + a[i - 2]);
write(a[i], ' ');
end;
end.
- 01.01.1970 00:00
- thumb_up 25
Var
n1, n2, n3: integer;
begin
write('Введите очки на двух первых кубиках: ');
readln(n1, n2);
n3 := 10 - (n1 + n2);
writeln('Замок имеет код ', n1, n2, n3, n1, n2, n3, n1, n2, n3, n1);
end.
Тестовое решение:
Введите очки на двух первых кубиках: 3 5
Замок имеет код 3523523523
- 01.01.1970 00:00
- thumb_up 28
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.