Вопрос по информатике:
Составить программу которая находит количество натуральных чисел которые не делятся ни на одно из чисел 2,7,11
- 09.02.2015 05:41
- Информатика
- remove_red_eye 2312
- thumb_up 25
Ответы и объяснения 1
var
s, k, err: integer;
str: string;
begin
writeln('Введённая пустая строка (без каких-либо символов) считается концом последовательности и, собственно, завершает выполнение программы, как бы говоря ей: "Эй, подруга! Выведи-ка количество чисел, не делящихся ни на два, ни на семь, ни на одиннадцать!"');
while (true) do
begin
readln(str);
val(str, k, err);
if (err > 0) then break;
if ((k mod 2 = 0) and (k mod 7 = 0) and (k mod 11 = 0)) then
inc(s);
end;
writeln(s);
end.
- 01.01.1970 00:00
- thumb_up 1
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.