Вопрос по информатике:
Помогите с паскалем! Написать программу. Составить блок схему.
Вставить заданное число в массив целых чисел перед последним четным элементом.
- 10.01.2017 00:46
- Информатика
- remove_red_eye 15421
- thumb_up 19
Ответы и объяснения 1
Const
m = 10;
var
a: array[1..m+1] of integer;
i, k: integer;
begin
write ('Исходный массив: ');
for i := 1 to m do
begin
a[i] := random(100);
write (a[i],'; ');
end;
writeln;
write('Введите число: ');
readln(k);
for i:=m+1 downto 1 do
begin
a[i]:=a[i-1];
if a[i] mod 2=0 then
begin
a[i-1]:=k;
break;
end;
end;
write('Измененный массив: ');
for i := 1 to m+1 do
write (a[i],'; ');
end.
- 01.01.1970 00:00
- thumb_up 7
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.