Вопрос по информатике:
Пусть задана последовательность чисел a, b, c, d. Составить программу вычисления количества K положительных чисел, содержащихся в
этой последовательности. Печатать a, b, c, d, K.
- 08.03.2018 03:42
- Информатика
- remove_red_eye 1778
- thumb_up 11
Ответы и объяснения 1
Var
a,b,c,d,K:integer;
begin
write('Введите a,b,c,d: ');
readln(a,b,c,d);
K:=0;
if a>0 then K:=K+1;
if b>0 then K:=K+1;
if c>0 then K:=K+1;
if d>0 then K:=K+1;
writeln(a,' ',b,' ',c,' ',d,' K=',K);
end.
Тестовое решение:
Введите a,b,c,d: -4 5 3 0
-4 5 3 0 K=2
- 09.03.2018 05:58
- thumb_up 18
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.