Вопрос по информатике:
Написать программу Паскаль - Вывести на экран элементы , которые больше значения элемента, номер которого введен с клавиатуры
- 13.06.2018 07:20
- Информатика
- remove_red_eye 6521
- thumb_up 33
Ответы и объяснения 1
Var
arr : array [1..30] of integer;
i, number : integer;
begin
//Заполнение массива случайными числами
for i := 1 to 30 do
arr[i] := Random(10000) - 5000;
//---
//Считывание номера элемента и проверка на соответствие условию
write('Введите число: ');
readln(number);
if not (number in [1..30]) then
begin
write('Ошибка. Номер элемента выходит за границу массива');
Exit;
end;
//---
//Вывод массива с учётом условия
for i := 1 to 30 do
if arr[i] > arr[number] then
write(arr[i], ' ');
//---
end.
- 14.06.2018 15:31
- thumb_up 33
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.