Вопрос по информатике:
Структурные операторы в языке pascal: Развилка и выбор.
1.Даны целые цисла m и n. если числа не равны, то заменить каждое из них одним и тем же числом, равным большему из исходных, а если равны, то заменить числа нулями.
2.Составить программу, которая по заданному году и номера месяца m определяет количество дней в этом месяце.
- 14.04.2015 08:52
- Информатика
- remove_red_eye 9328
- thumb_up 32
Ответы и объяснения 1
Первая прога:
program pr1;
uses crt
var m,n:real;
begin
clrscr;
writeln('insert the numbers');
readln(m, n);
if m n then begin
if m > n then begin
n:=m;
end
else begin
m:=n;
writeln(m,n);
end;
end
else begin
m:=0;
n:=0;
writeln(m,n);
end;
end.
Вторая прога:
program pr2;
ues crt
var y,m,d,k: integer;
begin
clrscr;
writeln('insert the year);
readln(y);
writeln('insert the month');
readln(m);
if m > 12 then begin
writeln('error');
end;
if m mod 2 0 then begin
d:= 31;
end;
if m=2 then begin
d:= 28;
end;
if m mod 2 = 0 then begin
d:=30;
end;
writeln('the number of the days in your month:');
writeln(d);
end.
- 15.04.2015 20:39
- thumb_up 34
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.