Вопрос по информатике:
Написать программу на pascal:дана матрица b состоящая из целых чисел получить матрицу r значения которой равны удвоенным значениям матрицы b
- 23.01.2017 03:34
- Информатика
- remove_red_eye 9678
- thumb_up 43
Ответы и объяснения 2
Uses crt;
var b:array[1..100,1..100] of integer;
r:array[1..100,1..100] of integer;
str,stb,i,j:integer;
Begin
randomize;
clrscr;
Writeln('Введите количество строк : ');
Read(str);
Writeln('Введите количество Столбцов: ');
Readln(stb);
writeln;
writeln('Matrica B');
For i:=1 to str do
begin
For j:=1 to stb do begin
b[i,j]:=random(30)+1;
r[i,j]:=2*b[i,j];
write(b[i,j]:3,' ');
end;
writeln;
end;
writeln;
writeln('Matrica R');
for i:=1 to str do
begin
for j:=1 to stb do
begin
write(r[i,j]:3,' ');
end;
writeln;
end;
readln;
end.
Запускаем , и первом делом создаём двухмерный массив Введя числа(когда программа запросит) не превышающий числа 100 (Строки и столбцы) ... после как мы ввели числа создается массив заполняя массив случайными числами в диапазоне 1..30.. И выводим Массив B, после удваиваем каждый элемент и заносим удвоенный результат в масссив R, и тоже выводим
- 25.01.2017 07:48
- thumb_up 21
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.
