Вопрос по информатике:
Задан вид квадратного уравнения ах квадрат +bx+c=0, коэффициенты a,b,c. Найти корни уравнения x1,x2.
1. Разработать схему алгоритма программы
2. Составить программу на языке Паскаль по разработанному алгоритму
- 02.08.2018 09:06
- Информатика
- remove_red_eye 2620
- thumb_up 21
Ответы и объяснения 1
Var a,b,c,d,x1,x2:real;
begin
writeln('Решение квадратных уравнений');
writeln('');
writeln('Введите коэффициенты a,b,c:');
readln(a,b,c);
d:=sqr(b)-4*a*c;
if d<0 then writeln('Корней нет');
if d=0 then begin x1:=-b/(2*a);
writeln('Один корень:');
writeln(x1:4:2);
end;
if d>0 then begin
x1:=-b+sqrt(d)/(2*a);
x2:=-b-sqrt(d)/(2*a);
writeln('Корни уравнения:');
writeln(x1:4:2);
writeln(x2:4:2);
end;
end.
- 03.08.2018 21:55
- thumb_up 36
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.