Вопрос по информатике:
Нужна помощь, буду очень благодарен.
Создайте файл f, компоненты которого являются действительными числами. Напишите программу вычисления суммы компонентов файла f и произведения ненулевых компонентов этого файла.
Язык программирования: Pascal
- 12.05.2018 06:23
- Информатика
- remove_red_eye 8854
- thumb_up 44
Ответы и объяснения 2
Cvar
f: Text;
k: integer;
s, p: longint;
i: integer;
begin
Assign(f, 'output.dat');
Rewrite(f);
writeln('Вводите данные, окончание число 7777');
repeat
read(k);
if k7777 then writeln(f,k)
until k=7777;
Close(f);
Reset(f);
s := 0;
p := 1;
writeln;
while not Eof(f) do
begin
readln(f, k);
write(k:4);
s := s + k;
if k 0 then p := p * k
end;
Close(f);
writeln;
writeln('Сумма= ', s, ', произведение= ', p)
end.
Вводите данные, окончание число 7777
3
6
-4
6
2
-3
-4
2
6
0
5
-1
7777
3 6 -4 6 2 -3 -4 2 6 0 5 -1
Сумма= 18, произведение= 622080
- 13.05.2018 03:12
- thumb_up 2
Uses crt;
var f:text;
i,x,sm,n:integer;
pr:longint;
begin
randomize;
clrscr;
pr:=1;
assign(f,'f.txt'); rewrite(f);
writeln('Введите число заполнений (например 6, в файле будет шесть натуральных чисел) ?'); readln(n);
for i:=1 to n do
begin
write(i,') ');
readln(x);
writeln(f,x);
end;
close(f);
reset(f);
while not Eof(f) do
begin
read(f,x);
sm:=sm+x;
if x 0 then pr:=pr*x;
end;
if n 0then
begin
writeln;
writeln('Сумма всех чисел = ',sm);
writeln('Произведение всех чисел = ',pr);
end else writeln('Файл пустой.');
readkey;
close(f);end.
- 14.05.2018 15:50
- thumb_up 49
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.