Вопрос по информатике:
Сделайте пожалуйста программу и блок-схему к задаче:
Даны два действительных положительных числа x и y.
Тригонометрические действия над числами пронумерованы (1 - sin, 2 - cos, 3 - tg,
4 - ctg). Составить программу, которая по введенному номеру n выполняет то или
иное действие над числами x и y.
- 17.01.2017 11:50
- Информатика
- remove_red_eye 19333
- thumb_up 21
Ответы и объяснения 1
Var
x, y, rx, ry: real;
n: integer;
s: string;
begin
writeln('Введите два положительных числа');
readln(x, y);
writeln('Введите код операции от 1 до 4');
readln(n);
case n of
1: begin rx := sin(x); ry := sin(y); s := 'sinX' end;
2: begin rx := cos(x); ry := cos(y); s := 'cosX' end;
3: begin rx := tan(x); ry := tan(y); s := 'tgX' end;
4: begin rx := 1 / tan(x); ry := 1 / tan(y); s := 'ctgX' end;
else begin rx := 0; ry := 0; s := '???' end
end;
writeln('Результаты для ', s, ': ', rx, ', ', ry)
end.
Тестовое решение:
Введите два положительных числа
4 5
Введите код операции от 1 до 4
2
Результаты для cosX: -0.653643620863612, 0.283662185463226
- 18.01.2017 12:15
- thumb_up 7
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.