Вопрос по информатике:
Даны
вещественные числа a, b, c. Выяснить, имеет ли уравнение ах2 + bx +
c = 0 вещественные корни.
Написать программу!
- 07.11.2015 07:54
- Информатика
- remove_red_eye 15844
- thumb_up 51
Ответы и объяснения 1
Var a,b,c,d:real;
begin
write('Введите коэффициенты a, b, c: ');
readln(a,b,c);
d:=(b*b-4*a*c);
if d<0 then writeln('Вещественных корней нет');
if d=0 then writeln('Один вещественный корень');
if d>0 then writeln('Два вещественных корня');
end.
- 08.11.2015 10:48
- thumb_up 14
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.