Вопрос по информатике:
Помогите решить в паскале
1) Составить программу для того, чтобы компьютер, используя генератор случайных чисел, записал на экране случайное число, значение которого лежит в пределах от 5 до 6.
2) Введено 3-значное число. Вывести число в зеркальном отображении.
3)Введенное 4-значное число изменить так, чтобы 1-3 и 2-4 цифры поменялись местами.
- 25.04.2018 04:46
- Информатика
- remove_red_eye 19496
- thumb_up 29
Ответы и объяснения 1
Program task1;
var a :integer;
begin
randomize; a:= 0; while (a 5) and (a 6) do a:= random(7); writeln(a);
end.
program task2;
var Digit, i :integer; DigitStr :string;
begin
readln(Digit); str(Digit,DigitStr); for i:= length(DigitStr) downto 1 do write(DigitStr[i]);
end.
program task3;
var Digit :integer; NewDigit, DigitStr :string;
begin
readln(Digit); str(Digit,DigitStr); NewDigit:= DigitStr[3] + DigitStr[4] + DigitStr[1] + DigitStr[2]; writeln(NewDigit);
end.
- 27.04.2018 00:00
- thumb_up 45
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.