Вопрос по информатике:
Помогите написать программу в pascal.Дан набор слов, разделенных точкой с запятой (;). Набор заканчивается двоеточием (:). Определить, сколько в нем слов, заканчивающихся буквой а.
- 18.09.2017 20:19
- Информатика
- remove_red_eye 8314
- thumb_up 22
Ответы и объяснения 1
var
str: string;
i : byte;
begin
readln(str);
str := str.Replace(':', '');
foreach c: string in str.Split(';') do
if (c[c.Length] in ['a', 'а']) then //не уточнено, какого алфавита "а"
i += 1;
writeln(i);
end.
- 19.09.2017 03:00
- thumb_up 22
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.