Вопрос по информатике:
Написать программу.Дана матрица А, имеющая N строк и N столбцов. Сформируйте два одномерных массива. В один перешлите четные, а в другой — нечетные элементы матрицы. Выведите на экран все массивы.
помогите пожалуйста. пожалуйста срочна нужна помощь
- 10.09.2017 03:01
- Информатика
- remove_red_eye 7141
- thumb_up 48
Ответы и объяснения 1
Const n=5;
var a:array[1..n,1..n] of integer;
b,c:array[1..n*n] of integer;
k1,k2,i,j:integer;
begin
k1:=0;
k2:=0;
for i:=1 to n do
for j:=1 to n do begin
read(a[i,j]);
if odd(a[i,j]) then begin inc(k2); c[k2]:=a[i,j]; end
else begin inc(k1); b[k1]:=a[i,j]; end;
end;
writeln('Четные');
for i:=1 to k1 do
write(b[i],' ');
writeln();
writeln('Нечетные');
for i:=1 to k2 do
write(c[i],' ');
end.
- 11.09.2017 09:50
- thumb_up 15
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.