Вопрос по информатике:
Написать программу для ввода 10 чисел с клавиатуры,не превышающих 1000 и кратных 5. Найти сумму этих чисел. Срочнооо нада!!!!!!!!!!!!!!!!!!
- 11.12.2015 00:30
- Информатика
- remove_red_eye 8916
- thumb_up 8
Ответы и объяснения 2
Var
i,x,s:integer;
f:boolean;
begin
for i:=1 to 10 do
begin
f:=false;
repeat
writeln('Введите число:');
readln(x);
if (x<=1000) and (x mod 5=0) then
begin
s:=s+x;
f:=true;
end
else writeln('Число не удовлетворяет требованиям.');
until f;
end;
writeln('Сумма равна : ',s);
end.
- 11.12.2015 11:57
- thumb_up 25
Var a,b: integer;var M: array[1..10] of integer;begina:=1;while a1000 do beginreadln(a);b:=b+1;if a mod 10 = 5 then M[b]:=a;end;writeln(M[1]+M[2]+M[3]+M[4]+M[5]+M[6]+M[7]+M[8]+M[9]+M[10]);end.
- 12.12.2015 19:43
- thumb_up 16
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.