Вопрос по информатике:
На языке паскаль абс написать программу (Не глушилку , а нормальную программу)(желательно с помощью Циклов и If-ов)
Натуральное число называется совершенным, если оно равно сумме своих делителей, включая 1 и, естественно, исключая само число. Например, совершенным является число 6 (6=1+2+3).
Необходимо найти все совершенные числа, меньшие заданного числа N.
Формат входных данных
Вводится одно целое число N (1≤N≤100000).
Формат выходных данных
Требуется вывести все совершенные числа, меньшие заданного числа N.
Числа следует выводить в порядке возрастания, разделяя пробелами.
Примеры
входные данные выходные данные
7 6
- 13.12.2017 23:58
- Информатика
- remove_red_eye 15088
- thumb_up 22
Ответы и объяснения 1
Ну Хьюстон почти все уже сделал. Я чуток подправил
var i,j,s,n:integer;
begin
readln(n);
for i := 1 to n-1 do
begin
s:=0;
for j := 1 to (i div 2) do
if i mod j=0 then s:=s+j;
if s=i then write(i,' ');
end;
end.
- 14.12.2017 10:19
- thumb_up 11
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.