Вопрос по информатике:
Написать программу на паскале которая определяет, каков процент пробелов во введенном тексте.
- 07.07.2016 12:48
- Информатика
- remove_red_eye 5603
- thumb_up 11
Ответы и объяснения 1
Var
s: string;
i, n, k: integer;
begin
writeln('Введите текст');
readln(s);
n := Length(s);
k := 0;
for i := 1 to n do
if s[i] = ' ' then k := k + 1;
writeln('Количество пробелов в тексте- ', k)
end.
Тестовый пример:
Введите текст
А роза упала на лапу Азора, а тут ДВА пробела , а тут вообще пять: : Все!
Количество пробелов в тексте- 21
- 08.07.2016 01:13
- thumb_up 36
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.