Вопрос по информатике:
Написать программу на паскале, которая определяет количество предложений во введенном тексте.
- 02.11.2017 19:17
- Информатика
- remove_red_eye 9118
- thumb_up 8
Ответы и объяснения 1
в предложении "персональный компьютер фирмы Apple" имеются 4 слова, отделенные друг от друга 3 пробелами.
Из приведенного примера видно, что количество слов в строке можно определить как сумму имеющихся в строке пробелов плюс единица.
program help;
Uses Crt;
var
i,k,ks,1:integer; с: char; s:string;
begin
ClrScr;
writeln('Введите строку. Ввод завершите нажатием клавиши Enter');
writeln;
readln(s) ;
l:=length(s);
k:=0;(k - счетчик количества пробелов}
for i:= 1 to 1 do
begin
c:=s;
if c=' ' then k:=k+l
end;
ks:=k+l;
writeln;
writeln('количество слов в данной строке составляет ',ks);
readln
end.
- 03.11.2017 15:56
- thumb_up 6
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.