Вопрос по информатике:
Написать программу в Pascal, используя массивы.
Дано массив А[1..n]. Сделать программу которая выводит те элементы массива? индексы которых являются степени двойки
Желательно с обьяснением строк
- 06.07.2018 03:40
- Информатика
- remove_red_eye 16973
- thumb_up 28
Ответы и объяснения 1
Const
n = 100;
var
a: array[1..n] of integer;
i: integer;
begin
//заполняем массив случайными значениями в диапазоне [0;100]
Randomize; //инициализация датчика случайных чисел
for i := 1 to n do a[i] := random(100);
i := 1; //1 - это два в нулевой степени
while i < n do
begin
writeln('a(', i, ')=', a[i]);
i := 2 * i; //удваиваем индекс, чтобы получить очередную степень двойки
end
end.
Результат работы программы:
a(1)=26
a(2)=21
a(4)=29
a(8)=74
a(16)=23
a(32)=44
a(64)=20
- 07.07.2018 21:03
- thumb_up 38
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.