Вопрос по информатике:
Напишите программу формирования и вывода массива размером 6 х 3, каждые три последовательных элемента в строке которого составлены по следующему правилу:
1-ый -- равен случайному числу;
2-ой -- равен целой части квадратного корня из предыдущего элемента;
3-ий -- равен сумме двух предыдущих элементов.
- 12.11.2016 01:42
- Информатика
- remove_red_eye 13263
- thumb_up 39
Ответы и объяснения 1
Var
i, j: integer;
a: array[1..6, 1..3] of real;
b: real;
begin
Randomize;
for i := 1 to 6 do
begin
b := random(1000);
a[i, 1] := b;
a[i, 2] := int(sqrt(b));
a[i, 3] := b + a[i, 2];
writeln(a[i, 1], ' ', a[i, 2], ' ', a[i, 3])
end
end.
Результат работы программы в PascalABC.NET:
61 7 68
291 17 308
3 1 4
515 22 537
236 15 251
571 23 594
- 13.11.2016 13:59
- thumb_up 31
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.