Вопрос по информатике:
Составить программу для определения, принадлежит ли точка с координатами (X Y) области ограниченной неравенством { x²+(y-1)≤4 y≥x/2 находится на границе области или находится вне ее области
- 09.09.2017 03:25
- Информатика
- remove_red_eye 10457
- thumb_up 14
Ответы и объяснения 1
Доброго времени суток!
Для начала немного поработаем над системой неравенств.
Дана система:
произведем несколько манипуляций с числами чтобы выявить абсолютные величины:
опираясь на абсолютные величины мы смело можем сказать что справедливы все "y" и "x" значения которые удовлетворяют двум неравенствам (отсюдого она и система). Можно канечно пошаманить и решить систему до конца указав области значений обоих переменных, но мы этого делать не будем, иначе для чего нам компьютер с потенциально огромной вычислительной мощностью? Правильно! Поэтому мы заставим его решать нашу систему неравенств ;)
программа будет написана на языке C++!
#include
// определяем коды, которые покажут нам результат работы функции.
#define CODE_INCASE 1
#define CODE_ONLINE 2
#define CODE_OUTRANGE 0
#define CODE_ERROR -1
struct vector2
{
int x,y;
};
unsigned char check_point(vector2 & point)
{
if ((point.x < 2*point.y) && (point.y < 5-point.x^2)) //определяем принадлежность
{
return CODE_INCASE; // является исключительно вложенным и не пересекает границы
}
else if( ((point.x = 2*point.y) && (point.y <= 5-point.x^2)) || ((point.x <= 2*point.y) && (point.y = 5-point.x^2)) )
{
return CODE_ONLINE; // пересекает границы частично или полностью
}
else
{
return CODE_OUTRANGE; // не принадлежит
}
return CODE_ERROR; // код ошибки (в случае взбоя алгоритма определения значений)
}
void main()
{
vector2 point1 = {-8, 12}; //тут мы задаем координату в виде простой линейной структуры.
std::cout << "{" << point1.x << "," << point1.y << "}, code " << check_point(point1) << std::endl; //выводим на экран код обработчика.
}
Удачи ;)
- 01.01.1970 00:00
- thumb_up 7
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.