Вопрос по информатике:
Дан массив из N целых чисел. Найти номер первого элемента, который равен количеству элементов, кратных 3.
Составить программу АЛГОРИТМА ПОИСКА в Паскале
- 25.10.2017 06:53
- Информатика
- remove_red_eye 16776
- thumb_up 10
Ответы и объяснения 1
Var
n,i,x:integer;
a:array[1..20]of integer;
begin
write('Массив: ');
for i:=1 to 20 do
begin
a[i]:=random(1,9);
write(a[i],' ');
if a[i] mod 3=0 then n:=n+1;
end;
writeln;
for i:=20 downto 1 do
if a[i]=n then x:=i;
writeln('Ответ: ',x)
end.
- 26.10.2017 03:13
- thumb_up 22
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.