Вопрос по информатике:
Помогите пожалуйста! Срочно надо написать программу в паскале. Задание: Введите три трёхзначных числа. Найти разность между наибольшим м наименьшим. Заранее спасибо!
- 07.04.2018 05:32
- Информатика
- remove_red_eye 11878
- thumb_up 15
Ответы и объяснения 1
Begin
var a, b, c: single;
readln(a, b, c);
writeln(max(a, max(b, c)) - min(a, min(b, c)));
end.
Позязя, расширеннее...
begin
var a, b, c, d, e: single;
readln(a, b, c);
if (a < b) then
d := a
else
d := b;
if (c < d) then
d := c;
if (a > b) then
e := a
else
e := b;
if (c > e) then
e := c;
writeln(e - d);
end.
- 08.04.2018 02:56
- thumb_up 38
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.