Вопрос по информатике:
Напишите программу, которая выполняет циклический сдвиг части массива, начиная с элемента с номером K и заканчивая элементом с номером M(включительно), влево на R элементов.
- 16.04.2018 04:15
- Информатика
- remove_red_eye 1146
- thumb_up 52
Ответы и объяснения 1
Var
i,k,m,r,p,j:integer;
a:array[1..10]of integer;
begin
writeln('Массив: ');
for i:=1 to 10 do
begin
a[i]:=random(10);
write(a[i],' ');
end;
writeln;
write('Введите K,M,R: ');
readln(k,m,r);
for i:=1 to r do
begin
j:=k;
p:=a[j];
while j
a[j]:=a[j+1];
j:=j+1
end;
a[j]:=p;
end;
writeln('Измененный массив:');
for i:=1 to 10 do write(a[i],' ');
end.
- 17.04.2018 22:09
- thumb_up 51
Знаете ответ? Поделитесь им!
Есть сомнения?
Не нашли подходящего ответа на вопрос или ответ отсутствует? Воспользуйтесь поиском по сайту, чтобы найти все ответы на похожие вопросы в разделе Информатика.
Трудности с домашними заданиями? Не стесняйтесь попросить о помощи - смело задавайте вопросы!
Информатика — наука о методах и процессах сбора, хранения, обработки, передачи, анализа и оценки информации с применением компьютерных технологий, обеспечивающих возможность её использования для принятия решений.